VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
This was a false alert caused by the monitoring system.
Posted 5 days ago. Sep 12, 2019 - 07:45 UTC
Investigating
We have detected that some users may be unable to join VidyoConnect™ meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted 5 days ago. Sep 12, 2019 - 07:39 UTC
This incident affected: VidyoConnect™ (Meetings).