VidyoPlatform™ EU - Difficulty starting and joining meetings

Incident Report for VidyoCloud™

Resolved

This incident has been resolved.
Posted May 13, 2025 - 22:11 UTC

Investigating

We are receiving reports that some users may be unable to join VidyoPlatform EU meetings.

Our team is working to identify the root cause and implement a solution.
Posted May 13, 2025 - 19:10 UTC
This incident affected: VidyoPlatform™ EU (VidyoPlatform™ EU Meetings).