VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
This was a false alert. All systems are normal.
Posted about 1 month ago. Sep 16, 2019 - 21:51 UTC
Investigating
We have detected that some users may be unable to join VidyoConnect™ meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted about 1 month ago. Sep 16, 2019 - 21:45 UTC
This incident affected: VidyoConnect™ (Meetings).