VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
False alarm. System is fully operational.
Posted 27 days ago. Sep 20, 2019 - 20:54 UTC
Investigating
We have detected that some users may be unable to join VidyoConnect™ meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted 27 days ago. Sep 20, 2019 - 20:51 UTC
This incident affected: VidyoConnect™ (Meetings).