VidyoEngage™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
False monitoring alert. System tests OK.
Posted 3 months ago. Jun 19, 2019 - 12:14 UTC
Investigating
We have detected that some users may be unable to start or join VidyoEngage™ Meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted 3 months ago. Jun 19, 2019 - 11:29 UTC
This incident affected: VidyoEngage™ (VidyoEngage™).