VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
We are looking into possible issue...
Posted 22 days ago. Jun 04, 2019 - 07:21 UTC
Investigating
We are receiving reports that some users may be unable to join VidyoConnect™ meetings.

Our team is working to identify the root cause and implement a solution.
Posted 22 days ago. Jun 04, 2019 - 07:14 UTC
This incident affected: VidyoConnect™ (Meetings).