VidyoWorks™ Health - Difficulty starting and joining meetings via VidyoVoice
Incident Report for VidyoCloud™
Resolved
This incident has been resolved and no other instances have been detected or reported.
Posted about 1 month ago. Aug 13, 2019 - 12:25 UTC
Investigating
We are receiving reports that some users may be unable to join VidyoWorks™ Health meetings via VidyoVoice.

Our team is working to identify the root cause and implement a solution.
Posted about 1 month ago. Aug 13, 2019 - 12:09 UTC
This incident affected: VidyoWorks™ Health (Telephone Services).