VidyoWorks™ - Difficulty starting and joining meetings via VidyoVoice
Incident Report for VidyoCloud™
Resolved
This incident has been resolved.
Posted 23 days ago. Jun 03, 2019 - 00:07 UTC
Update
We are continuing to monitor for any further issues.
Posted 23 days ago. Jun 02, 2019 - 23:24 UTC
Monitoring
Service has been restored. We will continue to monitor the situation to confirm service reliability.
Posted 23 days ago. Jun 02, 2019 - 23:23 UTC
Investigating
We are receiving reports that some users may be unable to join VidyoWorks™ meetings via VidyoVoice.

Our team is working to identify the root cause and implement a solution.
Posted 23 days ago. Jun 02, 2019 - 21:16 UTC
This incident affected: VidyoWorks™ (Telephone Services).