VidyoEngage™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
This was a false alarm.
Posted 6 days ago. Sep 11, 2019 - 10:48 UTC
Investigating
We have detected that some users may be unable to start or join VidyoEngage™ Meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted 6 days ago. Sep 11, 2019 - 10:43 UTC
This incident affected: VidyoEngage™ (VidyoEngage™).