VidyoEngage™ EU - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
Looks to be a false alert, system tests ok.
Posted 28 days ago. May 28, 2019 - 17:48 UTC
Investigating
We are receiving reports that some users may be unable to start or join VidyoEngage™ EU Meetings.

Our team is working to identify the root cause and implement a solution.
Posted 28 days ago. May 28, 2019 - 17:43 UTC
This incident affected: VidyoEngage™ (VidyoEngage™ EU).