VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
This issue has been resolved.
Posted about 1 month ago. Aug 10, 2019 - 07:29 UTC
Investigating
We have detected that some users may be unable to join VidyoConnect™ meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted about 1 month ago. Aug 10, 2019 - 06:55 UTC
This incident affected: VidyoConnect™ (Meetings).