VidyoEngage™ Health - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
False positive alert due to planned Maintenance.
Posted about 2 months ago. May 03, 2019 - 23:53 UTC
Investigating
We are receiving reports that some users may be unable to start or join VidyoEngage™ Health Meetings.

Our team is working to identify the root cause and implement a solution.
Posted about 2 months ago. May 03, 2019 - 23:07 UTC
This incident affected: VidyoEngage™ (VidyoEngage™ Health).