VidyoConnect™ - Difficulty starting and joining meetings via VidyoVoice
Incident Report for VidyoCloud™
Resolved
This incident has been resolved.
Posted 23 days ago. Jun 03, 2019 - 00:09 UTC
Monitoring
Service has been restored. We will continue to monitor the situation to confirm service reliability.
Posted 23 days ago. Jun 02, 2019 - 23:22 UTC
Update
We are continuing to investigate this issue.
Posted 23 days ago. Jun 02, 2019 - 21:53 UTC
Update
Our upstream provider, Google Cloud Platform, is currently experiencing an issue which is affecting our ability to stabilize the service. See https://status.cloud.google.com/ for more details. We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted 23 days ago. Jun 02, 2019 - 20:29 UTC
Investigating
We are receiving reports that some users may be unable to join VidyoConnect™ meetings via VidyoVoice.

Our team is working to identify the root cause and implement a solution.
Posted 23 days ago. Jun 02, 2019 - 18:52 UTC
This incident affected: VidyoConnect™ (Telephone Services).