Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
This incident has been resolved and no other instances have been detected or reported.
Posted Sep 16, 2020 - 04:46 UTC
Monitoring
Service has been restored. Our team is continuing to monitor the issue.
Posted Sep 15, 2020 - 23:37 UTC
Investigating
We are receiving reports of users unable to join meetings

Our team is working to identify the root cause and implement a solution. Some users may be affected.
Posted Sep 15, 2020 - 20:15 UTC
This incident affected: VidyoConnect™ Health Edition (Health Meetings).