VidyoConnect™ - Difficulty starting and joining meetings
Incident Report for VidyoCloud™
Resolved
False positive alert related to scheduled emergency maintenance. All systems operational.
Posted 21 days ago. Aug 27, 2019 - 02:41 UTC
Investigating
We have detected that some users may be unable to join VidyoConnect™ meetings.

Our team is working to verify if there is an issue and will send an update shortly.
Posted 21 days ago. Aug 27, 2019 - 02:29 UTC
This incident affected: VidyoConnect™ (Meetings).